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ME1110 Digital Modulation Technique
Lab 6
Quadrature Amplitude Modulation (QAM)
____________________________________________________________________________
This courseware product contains scholarly and technical information and is protected by copyright laws and international treaties. No part of this publication may be reproduced by any means, be it transmitted, transcribed, photocopied, stored in a retrieval system, or translated into any language in any form, without the prior written permission of Acehub Vista Sdn Bhd.  

The use of the courseware product and all other products developed and/or distributed by DreamCatcherTM are subject to the applicable License Agreement. 

For further information, see Courseware Product License Agreement.
____________________________________________________________________________
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Objectives

i) To study the digitally modulated quadrature amplitude modulation (16-QAM and 64-QAM) waveforms using an oscilloscope 

ii) To measure the bandwidth and power of the modulated 16-QAM and 64-QAM signals using an oscilloscope and the VSA software
iii) To demodulate the modulated 16-QAM and 64-QAM signals using the VSA software
iv) To measure the error vector magnitude (EVM) of the modulated 16-QAM and 64-QAM signals using an oscilloscope and the VSA software
Equipment Required

i) ME1110 Digital Modulation Training Kit

ii) Keysight MSOX 3000 series 4 Channels Mixed Signal Oscilloscope with a minimum of 100 MHz bandwidth*

*Note: For users with the Keysight DSOX 3000 series oscilloscope, self-customization on certain experiment procedures is required to obtain the expected experiment results. 
Accessories Required

i) A PC running Microsoft® Windows XP/Vista®, pre-installed with the following:

a. Keysight 89601A VSA software version 16.0 or higher [with option 200, 300, AYA]
b. Keysight IO Libraries Suite software version 14.1 or higher for instrument connection

ii) 1 × SMA(m)-to-BNC(m) coaxial cable, 1.0 m

iii) 3 ×Oscilloscope Probes

iv) 1 ×Oscilloscope Digital Logic Probe

v) 1 × USB cable 
1. Introduction

Quadrature Amplitude Modulation (QAM)
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Figure 1 – 16-QAM Constellation and IQ Amplitude Mapping

















Figure 2 – 64-QAM Constellation and IQ Amplitude Mapping

2.
Measuring and Verifying IQ and 16-QAM Modulated Signals
1. Make the following connections (as shown in Figure 3).

By using three oscilloscope probes, connect the I, Q, and Output RF ports of the ME1100 training kits to the respective Channel 2, Channel 3, and Channel 1 of an oscilloscope. Note that Channel 1 represents I-baseband signal,Channel 2 represents Q-baseband signal, and Channel 3 represents the modulated ASK signal. At the rear panel of oscilloscope, connect the digital channel D1 to Baseband Data port, D0 to Clock, and D2 to Symbol Clock port. Set the training kit to Mode 8 for the 16-QAM modulation.






















Figure 3 – Basic Setup for IQ Baseband Signal Measurement and Verification
2. Verify the generated IQ waveform with the recommended oscilloscope. Figure 4 shows a sample of the measured IQ waveform using the MSOX 3000 series oscilloscope. Note that you will have to use a positive edge (rising) trigger in the oscilloscope with the clock port (D1) in order to see a stable waveform, as shown in Figure  Note that you will have to press the [Edge] key in the Trigger section of the front panel to display the Edge Trigger Menu, and then select D1 as source and rising as slope. 
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Figure 4 – Measured IQ and Modulated 16-QAM Waveform in Oscilloscope
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Figure 5 – Setting Trigger in Oscilloscope

3. Base on the baseband data in Figure 4, what are the binary bit streams going into the modulator? How many bits are represented in a symbol in the 16-QAM modulation?

4. Using the mapping table in Figure 1, verify the measured I and Q signals based on the baseband data identified in step 3.

                        1000     0010      0110      0100      0101     0001     1011      0111     0000      0011     1100


  8           2            6           4            5           1           B            7           0            3           C
   
                        S8        S2        S6        S4       S5        S1        S11      S7       S0        S3        S12           
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Figure 6 – Measured I and Q Signals Based on 16-QAM Mapping in 4 Bits per Symbol 
Note that the measured I and Q have a 1 symbol delay.

5. Change the time base of the oscilloscope to view the phase changes. A clear phase and amplitude change is shown in Figure 7.
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Figure 7 – Measured IQ and 16-QAM Signals in Oscilloscope with Zoomed Time Base
3.
Measuring and Verifying IQ and 64-QAM Modulated Signals

1. Using the same setup as shown in Figure 3, measure the 64-QAM modulated signal together with its IQ signals. Set the training kit to Mode 9 for the 64-QAM modulation. The measured signal is shown below.
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Figure 8 – Measured IQ and Modulated 64-QAM Waveform in Oscilloscope
2. Based on the baseband data in Figure 8, what are the binary bit streams going into the modulator? How many bits are represented in a symbol in 64-QAM modulation?
3. Use the mapping table in Figure 2, verify the measured I and Q signals of based on the baseband data identified in step 2.

                               011000       100101         110000      101111         010101        010111          111110
       

        (18)
 (25)
          (30)
  (2F)
          (15)
    (17)

(3E)


    
                               S24            S37            S48           S47            S21            S23             S62      
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Figure 9 – Measured I and Q Signals Based on 16-QAM Mapping in 4 Bits per Symbol
Note that the measured I and Q have 1 symbol delay.
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Figure 10 – Measured IQ and 64-QAM Signals in Oscilloscope with Zoomed Time Base
4.
Measuring the 16-QAM Modulated Signal in 89600 VSA Software

1. Make the following connections in the ME1110 training kit.

Connect the Output RF port of the training kit to the Channel 1 in the oscilloscope. At the rear panel of the oscilloscope, use an USB-to-USB cable to connect a PC to the oscilloscope. Set the training kit to Mode 8 for the 16-QAM modulation.




















Figure 11 – Test Setup for Displaying the Modulated Signal in VSA Software

2. Configure the recommended oscilloscope to interface with the 89600 VSA software (via USB port). Refer to Lab 2 (Section 3, Step 2) for the detailed procedure on how to select the USB controller in the MSOX 3000 series oscilloscope.
3. Verify the oscilloscope connection by using the Keysight Connection Expert and ensure that the instrument and its VISA address are detected. Refer to Lab 2 (Section 3, Step 3).
4. Launch the 89600 VSA software. 

The VSA will be initialized and the detected hardware is shown below. The oscilloscope front panel is now disabled.
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Figure 12 – Detected Hardware Connected to VSA Software

5. Configure the VSA as follows (Refer to Lab 1, Section 3, Step 5-12):

	VSA Software Window
	Action

	Utilities > Hardware > Discovered Instruments
	Check whether Keysight MSOX 3000 series scope is detected

	Utilities > Hardware > Configurations
	S Select Keysight MSOX 3000 series scope to the assigned Analyzer (Analyzer 1, 2 or 3)

	Display format
	Set the display layout to Single and right-click to enable the Y Auto Scale

	MeasSetup > Frequency 
	Set the center frequency to 10 MHz and the frequency span to 3 MHz


6. Change the default Vector measurement type to Digital Demod. Select MeasSetup > Measurement Type > Digital Demod to demodulate the QAM signal.

7. Select MeasSetup > Digital Demod Properties to set the digital demodulation properties. In the Format tab, set the following parameters: Format = QAM 16, Symbol Rate = 250 kHz, Points/Symbol = 4, and Result Length = 320 Symbols. The software will occasionally stop and prompt a warning message regarding insufficient data for digital demodulation (e.g. it cannot synchronize to carrier and bit). Ignore the warning and continue with the setupClick the Run button.
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Figure 13 – Setting the Demodulation Format
8. In the Filter tab, set the following parameters: Measurement filter = Rectangular and Reference Filter = Rectangular. Leave the other settings as default.
[image: image10.png]Fomst  Fiter | semch | Conpersote | Advoncd | cutom Pk
Measurement Filter: Data Register:
D1 (Not valid)
efererce Fter Dt Regeter
Rednor o torvae

I Haf-Sine shaping (For 0QPSK)

alphafeT:
0.3
I Eikered by Receiver (for M3K Type 1)





Figure 14 – Setting the Demodulation Filter
9. Note that we need to turn off ‘Pulse Search’ option, as our carrier is present continuously.  Otherwise the software may limits the maximum symbols in the ‘Result Length’.  
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Figure 15 – Turning Off the Pulse Search Option

10. After setting the digital demodulation properties, the VSA software may override the frequency span selection.  Go to the MeasSetup window to change it to the preferred value.

11. Change the display to Grid 2 × 2 to display the demodulated signal as shown below. Note that the EVM is approximately 1.45%, with a magnitude error of approximately 1.1% and a phase error of approximately 1.0 degree. The IQ offset is about -48.99 dB. These represent the errors of the IQ modulator for the 16-QAM modulation.
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Figure 16 – Demodulation Display in Grid 2 × 2 after the 16-QAM Modulator
12.  Set the frequency span to 1 MHz (with the center frequency at 10 MHz) and set the averaging to RMS (Video) by 10 counts. Measure the OBW on Trace B (Ch1 Spectrum) window. Set the percentage of the bandwidth to around 91.6% in order to measure the first null bandwidth or main lobe bandwidth of the spectrum. The bandwidth is approximately         0.5 MHz, as shown in Figure 17.
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Figure 17 – Measuring OBW for the Main Lobe of the Modulated 16-QAM Signal
13. Note that the bandwidth is calculated using B = 2RS, where RS is the symbol rate used in this modulation (note that for 16-QAM, 4 bits per symbol, symbol rate is ¼ of the data rate). Using this formula, calculate the bandwidth of the modulated signal. Assume no pulse shaping is used in this modulation. 
Symbol rate of the modulated 16-QAM signal = __________ Msps

Bandwidth of the modulated 16-QAM signal = _________MHz

Does the calculated bandwidth correlate with the measured OBW?  
14. Next, on the same trace window (Trace B: Ch1 Spectrum), measure the band or channel power for the main lobe of the 16-QAM signal. Select Markers > Calculation, and click the check box for band power. Set the band power center frequency to 10 MHz and the span to 0.5 MHz (as calculated previously). Note that averaging is set to RMS (Video) by 10 counts. What is the measured band power?

Band power of the modulated 16-QAM signal = _________dBm   
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Figure 18 – Measuring Band Power of Main Lobe for 16-QAM Signal

15. Set the frequency span back to 3 MHz and average to 10 counts Change the Measurement Filter to Root Raised Cosine (RRC) and Reference Filter to Raised Cosine (RC), with Alpha/BT of 0.05. Did you notice the EVM value change? Determine the channel power, EVM, magnitude error, and phase error. Repeat the measurement for Gaussian filters.

	
	Channel Power

(dBm)
	EVM

(% rms)
	Magnitude Error (% rms)
	Phase Error

(deg)

	Meas Filter: Rectangular 

Ref Filter: Rectangular 


	
	
	
	

	Meas Filter: RRC

Ref Filter: RC

Alpha/BT: 0.05
	
	
	
	

	Meas Filter: Gaussian

Ref Filter: Gaussian

Alpha/BT: 0.05
	
	
	
	


16. The simulated waveform can be recorded by selecting Control > Record. To playback the captured data, select Control > Restart. To save the captured data, select File > Save > Save Recording. Refer to Lab 1, Appendix for the detailed procedure.
Exercise 1 
a. Use the following settings to display the IQ modulated 16-QAM signal in VSA: 
	Frequency Span
	6 MHz

	Frequency Points
	1601

	Averaging Type
	RMS (video) with 50 counts

	Result Length
	1000 symbols

	Points/symbol
	5


Will the above settings provide better accuracy for the measurement? 

b. What is the effect of different filter used in measurement on the demodulated EVM?

5.
Measuring the 64-QAM Modulated Signal in 89600 VSA Software
1. Using the same setup as shown in Figure 11, measure the 64-QAM modulated signal in the 89600 VSA software. Set the training kit to Mode 9 for the 64-QAM modulation.
2. Configure the VSA as follows (Refer to Lab 1, Section 3, Step 5-12):

	VSA Software Window
	Action

	Utilities > Hardware > Discovered Instruments
	Check whether Keysight MSOX 3000 series scope is detected

	Utilities > Hardware > Configurations
	Select Keysight MSOX 3000 series scope to the assigned Analyzer (Analyzer 1, 2 or 3)

	Display format
	Set the display layout to Single and right-click to enable the Y Auto Scale

	MeasSetup > Frequency 
	Set the center frequency to 10 MHz and the frequency span to 2.5 MHz

	MeasSetup > Measurement Type > Digital Demod
	To demodulate the 64-QAM signal

	MeasSetup > Digital Demod Properties
	Set Format to QAM 64, Symbol Rate to 166.67 kHz, Points/Symbol to 5, Result Length to 200 Symbols, Measurement filter and Reference Filter, both to Rectangular. Disable the pulse search option

	Display format
	Grid 2 × 2


3.  The demodulated 64-QAM signal in the Grid 2 × 2 display is shown below. Note that the EVM is approximately 1.17%, with a magnitude error of approximately 0.825% and a phase error of approximately 1.04 degrees. The IQ offset is about -61.45 dB. These represent  the errors of the IQ modulator for the 64-QAM modulation.
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Figure 19 – Demodulation Display in Grid 2 x 2 after the 64-QAM Modulator
4. Set the frequency span to 1 MHz (with the center frequency at 10 MHz) and set the averaging to RMS (Video) by 10 counts.Measure the OBW on Trace B (Ch1 Spectrum) window. Set the percentage of the bandwidth to around 93.3% in order to measure the first null bandwidth or the main lobe bandwidth of the spectrum. The bandwidth is approximately 332 kHz, as shown in Figure 20.
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Figure 20 – Measuring OBW for the Main Lobe of the Modulated 64-QAM Signal
5. Note that the bandwidth is calculated using B = 2RS = 2(Rb/3), where RS is the symbol rate used in this modulation (note that for 64-QAM, 6 bits per symbol, symbol rate is one third of data rate). Using this formula, calculate the bandwidth of the modulated signal. Assume no pulse shaping is used in this modulation. 
Symbol rate of the modulated 64-QAM signal = __________ Msps

Bandwidth of the modulated 64-QAM signal = _________MHz

Does the calculated bandwidth correlate with the measured OBW? 
6. Next, on the same trace window (Trace B: Ch1 Spectrum), measure the band or channel power for the main lobe of the 64-QAM signal. Select Markers > Calculation and click the check box for band power. Set the band power center frequency to 10 MHz and the span to 0.3333 MHz (as calculated previously). Note that averaging is set to RMS (Video) by 10 counts. What is the measured band power?

Band power of the modulated 64-QAM signal = _________dBm 
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Figure 21 – Measuring Band Power of Main Lobe for 64-QAM Signal

7. Set the frequency span back to 2.5 MHz and average to 10 countsChange the Measurement Filter to Root Raised Cosine (RRC) and Reference Filter to Raised Cosine (RC), with Alpha/BT of 0.05. Did you notice the EVM value change? Determine the channel power, EVM, magnitude error, and phase error. Repeat the measurement for Gaussian filters.

	
	Channel Power

(dBm)
	EVM

(% rms)
	Magnitude Error (% rms)
	Phase Error

(deg)

	Meas Filter: Rectangular 

Ref Filter: Rectangular 


	
	
	
	

	Meas Filter: RRC

Ref Filter: RC

Alpha/BT: 0.05
	
	
	
	

	Meas Filter: Gaussian

Ref Filter: Gaussian

Alpha/BT: 0.05
	
	
	
	


8. The simulated waveform can be recorded by selecting Control > Record. To playback the captured data, select Control > Restart. To save the captured data, select File > Save > Save Recording. Refer to Lab 1, Appendix for the detailed procedure.
Exercise 2
a. Use the following settings to display the IQ modulated 64-QAM signal in VSA: 
	Frequency Span
	6 MHz

	Averaging Type
	RMS (video) with 50 counts

	Result Length
	1000 symbols

	Points/symbol
	5


Will the above settings provide a better accuracy for the measurement? 

b. What is the effect of different filter used in measurement on the demodulated EVM?
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Set this to 10x to 30x the number of symbols.  For 16-QAM we have 16 symbols.
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